Zumo660 problems

2 replies [Last post]
BobGoode's picture
Offline
Joined: 2010/10/07

Points: 0

After 5+ years of faultless service, my Zumo660 has recently decided not to display roadmaps and literally has no idea how to plot a route to a selected destination anymore. In addition, I normally plan routes on BaseCamp and then load the route onto the 660, which it ignores and just shows me a blank display (see pic). However maps display perfectly if I don't select 'where to' or tell it which route to follow. The unit has Basemap NR 5.01 & I have Garmap NT 2012.3 on the computer.

Perhaps it does not like the fact that I dont use it on a bike anymore.

Any ideas?

 

 

Let it be.

Offline
Joined: 2011/06/19
BobGoode's picture
Offline
Joined: 2010/10/07

Thanks Ruste, Found the kaaskop language a bit difficult to follow but got the gist of it in the end. Did the reset but the maps still don't show. So any more ideas?

 

Let it be.

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.

Events

« May 2018 »
MonTueWedThuFriSatSun
123456
78910111213
14151617181920
21222324252627
28293031

Liability

Motorsport is inherently dangerous.  As per paragraph 9 of the club constitution, the club shall not be held liable for any loss, injury or death of any member or guest, howsoever arising.

The BMW Motorrad Club Cape cannot be held responsible or liable in any way for any actions or decisions you make as a result of the information posted on this site.  Although this site is enabled and used by the BMW Motorrad Club Cape, posts are made by members, non-members, advertisers and guests and none of it is vetted by the club before posting.  This is the internet and Africa - you are responsible for yourself.

User login

CAPTCHA
Just to make sure you're human!